To continue using Vankyo Forum, we have sent a verification link to your email. Please verify your email address. Click here to resend the verification link.

Trouble with wireless update for S30 Tablet


I've been having trouble updating my S30 tablet. It says I have a wireless update for 6/11/20 and the first few times I tried it, it would download, install and then go into recovery mode where I saw the Android icon and then all it said was "error!" and then would reboot. This happened at least 3 times and I made sure there was well enough battery power every time.

Eventually, it stopped prompting me, so I went into the settings and did a manual check for an update and it said my system was up to date, so I thought it fixed itself.

Now, it's prompting me again. I repeated the instructions with the same results. Error! at recovery mode and then it boots back into the program. I even did a factory reset and then tried to update and nothing works.


  • I am stuck in a loop, does this have a special way to factory reset? Right now it is unusable.

  • If I try to manual update it says update exist but if I attempt upload I get a failed to connect to

  • I've been having the same problem except I continue to get update prompts & I go through the same process mentioned in the previous comments in which I get an Error message once I download & attempt to install. I see that there hasn't been a response on this issue it would be nice if someone in either the community or the company support team would help to troubleshoot the issue.

Sign In or Register to comment.