To continue using Vankyo Forum, we have sent a verification link to your email. Please verify your email address. Click here to resend the verification link.

Latest S30 update (June 9, 2020) Bricked the tablet

edited July 11 in Ask the Community

It did the usual download and install, but now it is in a 10-sec reset loop and hasn't turned on since. I have tried multiple button presses, it even has a ¨Reset¨ button bit that just restarts the loop. I haven´t heard from the company via email or comments on this Forum. I cannot even get a response on how to do a Factory Reset, I would be happy with that.

Can someone please tell me how to factory reset the s30?

Thanks,

Todd

Comments

  • I heard from Vankyo on FB messenger and got this:

    However, it did not fix my tablet. I tried this multiple times and it still just loops between from dim Start up to dright Start Up screen. It acted like it wanted to go into Safe mode but never made it. I responded to them and hope to get the next step to try to fix it.

    Todd.

  • they have told you how to solve the problem I am the same with my tablet and the luck nor does it answer me very badly company they do nothing

  • Todd, I got the same "fix" from them and it didn't work for me either. I couldn't even get the Rockchip driver to install to do the firmware update but at least now I know it wouldn't have fixed it anyway. Thanks!

  • Newest Update: I talked with Amazon and they encouraged me to contact the seller. They quickly contacted me back and this morning I sent the tablet to them and they will send a replacement. I will update when I have it in hand.

  • I contacted the seller and they sent me a new one and I sent them the old one. So far, so good, it is asking for another wireless update. Not today!

Sign In or Register to comment.